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LIMITED WARRANTY ON MEDIA
AND REPLACEMENT

If you discover physical defects in
the manuals distributed with an
Apple product or in the media on
which a software product is distrib-
uted, Apple will replace the media
or manuals at no charge to you,
provided you return the item to be
replaced with proof of purchase to
Apple or an authorized Apple dealer
during the 90-day period after you
purchased the software. In addition,
Apple will replace damaged software
media and manuals for as long as
the software product is included in
Apple’s Media Exchange Program.
While not an upgrade or update
method, this program offers addi-
tional protection for up to two years
or more from the date of your
original purchase. See your author-
ized Apple dealer for program
coverage and details. In some
countries the replacement period
may be different; check with your
authorized Apple dealer.

ALL IMPLIED WARRANTIES ON
THE MEDIA AND MANUALS,
INCLUDING IMPLIED WAR-
RANTIES OF MERCHANTABIL-
ITY AND FITNESS FOR A
PARTICULAR PURPOSE, ARE
LIMITED IN DURATION TO
NINETY (90) DAYS FROM THE
DATE OF THE ORIGINAL RETAIL
PURCHASE OF THIS PRODUCT.

Even though Apple has tested the
software and reviewed the docu-
mentation, APPLE MAKES NO
WARRANTY OR REPRESENTA-
TION, EITHER EXPRESS OR
IMPLIED, WITH RESPECT TO
SOFTWARE, ITS QUALITY,
PERFORMANCE, MERCHANT-
ABILITY, OR FITNESS FOR A
PARTICULAR PURPOSE. AS A
RESULT, THIS SOFTWARE IS
SOLD “AS IS,” AND YOU THE
PURCHASER ARE ASSUMING THE
ENTIRE RISK AS TO ITS
QUALITY AND PERFORMANCE.

IN NO EVENT WILL APPLE BE
LIABLE FOR DIRECT, INDIRECT,
SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES
RESULTING FROM ANY DEFECT
IN THE SOFTWARE OR ITS
DOCUMENTATION, even if advised
of the possibility of such damages.
In particular, Apple shall have no
liability for any programs or data
stored in or used with Apple
products, including the costs of
recovering such programs or data.

THE WARRANTY AND REMEDIES
SET FORTH ABOVE ARE EXCLU-
SIVE AND IN LIEU OF ALL
OTHERS, ORAL OR WRITTEN,
EXPRESS OR IMPLIED. No Apple
dealer, agent, or employee is
authorized to make any modifi-
cation, extension, or addition to this
warranty.

Some states do not allow the
exclusion or limitation of implied
warranties or liability for incidental
or consequential damages, so the
above limitation or exclusion may
not apply to you. This warranty
gives you specific legal rights, and
you may also have other rights
which vary from state to state.
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& APPLE COMPUTER, INC.

This manual and the software
described in it are copyrighted,
with all rights reserved. Under
the copyright laws, this manual
or the software may not be
copied, in whole or part,
without written consent of
Apple, except in the normal use
of the software or to make a
backup copy of the software.
The same proprietary and
copyright notices must be
affixed to any permitted copies
as were affixed to the original.
This exception does not allow
copies to be made for others,
whether or not sold, but all of
the material purchased (with all
backup copies) may be sold,
given, or loaned to another
person. Under the law, copying
includes translating into
another language or format.

You may use the software on any
computer owned by you, but
extra copies cannot be made for
this purpose.

© Apple Computer, Inc., 1986
20525 Mariani Ave.
Cupertino, California 95014
(408) 996-1010

Apple, the Apple logo,
LaserWriter, and ProDOS are
registered trademarks of Apple
Computer, Inc.

Apple IIGS is a trademark of
Apple Computer, Inc.

The DeskTop program was
developed by Version Soft.

Macintosh is a trademark of
McIntosh Laboratories, Inc.,
and is being used with express
permission of its owner.

Microsoft is a registered trade-
mark of Microsoft Corporation.

POSTSCRIPT is a trademark of
Adobe Systems Incorporated.

ITC Garamond, ITC Avant
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Dingbats are registered
trademarks of International
Typeface Corporation.
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Chapter 1

Intfroducing the DeskTop

The DeskTop is a computer desktop that helps you manage your
disks and files easily.

The DeskTop shows you pictures, called icons, that represent your
disks and files, so it's easy to see where everything is. You just work
with the icons to copy, delete, or organize files.

The DeskTop also speeds up selecting and running applications.
You simply scan a visual desktop to find the application and then
click the application icon twice to start it.

Is the DeskTop for me?

Definitely. Most people who use the DeskTop find that it helps them
organize their work better and actually work faster.

However, if you are a first-time Apple® II user, put the DeskTop
away and spend a few weeks getting used to your computer and your
application programs. Then you’ll be able to understand the
DeskTop and appreciate what it can do for you.



What software will | use?

The DeskTop is ProDOS® based, so it works best with ProDOS disks
that are not copy protected.

You can, however, use the DeskTop to make backup copies of
unprotected DOS 3.3 or Pascal disks. And you can use it to start up
any Apple II application disk regardless of its operating system.

Should | make a backup copy
of the DeskTop?

Yes. In fact, in Chapter 3, you'll learn how to use the DeskTop to
make the copy. Then use the copy for your work and keep the
original in a safe place.

Chapter 1: Introducing the DeskTop



If you've never used a mouse
before, go through the training

disk that came with your
Apple lIGs™,

|

This chapter explains how to use the mouse with the computer
desktop. If you are already familiar with pulling down menus,
opening and moving windows, and selecting and opening icons,
skip to Chapter 3, “Getting Started With the DeskTop.”

Using the mouse

The best way to see how the mouse works is to start up the DeskTop
and try it yourself. To start up the DeskTop from the Program
Launcher, open the application called DESKTOP.SYS16. After a
few seconds, you should see the computer desktop, a screen similar
to the one shown in Figure 2-1.



Desktop

Pointer

3.5-inch disk

A file is a body of information
saved by name on a disk. It can
be a document or a program.

Trash

Figure 2-1
The computer desktop

When you first begin, your computer desktop will contain a Trash
icon and an icon representing your DeskTop disk. Later, when you
examine the contents of this disk, you will see icons representing
different files.

Moving the pointer

Watch the screen while you roll the mouse on a flat surface next to
your Apple II. The pointer mirrors every move of the mouse.

If you run out of room for the mouse, lift it and put it down where
you have more room. Lifting the mouse does not move the pointer.

Clicking
Pressing and releasing the mouse button is called clicking.
Double-clicking means rapidly pressing and releasing the mouse

button twice. Sometimes double-clicking is a shortcut for a DeskTop
command.

Chapter 2: Learning fo Use the Mouse and the DeskTop



Clicking serves a variety of functions. For example, in Chapter 3
you’ll learn how to start an application by clicking an application
icon.

Selecting

When you point to a word or picture and click the mouse button,
you are selecting that word or picture for some action.

Selecting is central to using the DeskTop and other mouse-based
applications. You select something and then you tell the DeskTop
what action to perform. For example, you might select a disk and
then tell the DeskTop to display its contents.

To select an icon, roll the mouse so the pointer is on top of it. Now,
click once. The icon will be highlighted.

You deselect by clicking somewhere else on the desktop.

Selecting multiple icons

If you're copying or deleting several files, you may want to select all
their icons at once. Position the pointer outside one corner of a
group of icons, hold down the mouse button, and drag diagonally
to the opposite corner of the group. As you drag, you'll see a
rectangle forming. When you release the mouse button, all the
icons within the rectangle will be highlighted.

Position the pointer on any one of the highlighted icons if you want
to drag the group to another part of the desktop. The icons stay
selected until you click anywhere outsigie any of them.

% Note: Another way to select multiple icons is to select the first
one and then hold down the Apple key while you select the
additional ones.

Using the mouse 5



Menu title
Menu bar

Dragging

You move an icon from one place to another by dragging it with the
mouse. To drag an icon, point to it and hold the mouse button
down while you move the pointer to the new location. The outline of
the icon moves as you move the mouse. When you release the
mouse button, the icon jumps to the new position.

As you'll learn in Chapter 3, you can delete files by dragging them
to the Trash or copy files by dragging them to another disk.

Pulling down menus

The menus in the DeskTop stay out of sight until you need them, but
their titles are shown on the menu bar. To pull down a menu, point
to the title of the menu and hold down the mouse button. The menu
will remain visible until you release the mouse button.

Some of the commands in 2 menu may be dimmed when you
pull it down. The DeskTop dims commands when they are not
appropriate at a particular time.

Selected command

DeskTop disk

Figure 2-2
A menu

Chapter 2: Learning to Use the Mouse and the DeskTop



Choosing menu commands

In the DeskTop, you usually select an icon and then indicate what
action you want to take by choosing a command from a menu.

To choose a command, point to the menu title, hold down the
mouse button, and drag the pointer down the list until the
command you want is highlighted; then release the button.

Working with windows

You look at the files on your disks through windows. The contents
of the windows will vary, but all of them have these things in
common: a title bar, a close box, a size box, and two scroll bars.
You can use these tools to change what you see through a window,
change the size of a window, move a window, close a window, and
activate a window.

For example, if you open the DeskTop disk, your screen will look

similar to the one in Figure 2-3. (To open the disk, select the icon
and then choose Open from the File menu. You can also open a
disk by double-clicking the disk icon.)

Title bar

Close box

Application icon

Folder icon

Document icon

Sl =

Scroll bar

Size box

Figure 2-3
Contents of a disk

Working with windows Z



Changing the size of a window

A window may be too small for you to see its contents or so big that
it obscures other windows on the desktop. To shrink a window, point
to the size box and drag it up and to the left. To expand a window,
point to the size box and drag it down and to the right.

Moving a window

If you have several windows open at once, and want to see the
contents of more than one at a time, you may need to rearrange
their position on the desktop. To move a window, point anywhere
in the title bar (except on the close box) and, holding down the
mouse button, drag the window to wherever you want to put it.

Activating a window

With the DeskTop, you can have several windows open on the
screen, but only one can be active at a time. A window has to be
active before you can make any changes to the information in it.

You can tell whether a window is active by looking at its title bar. The
active window'’s title bar is striped. To activate a window, click
anywhere in the window.

Changing the view through a window

Sometimes a window will show you only part of what is actually on
the disk. When the window is too small for you to see all the icons at
once, the scrolls bars along the right and bottom sides of the
window will be gray and will contain a scroll box. When you drag the
scroll box along the scroll bar, different parts of the window come
into view.

Chapter 2: Learning to Use the Mouse and the DeskTop



The vertical scroll bar on the right side of the window represents the
total length of the collection of icons; the horizontal scroll bar on
the bottom of the window represents the total width. If you want to
move down to the middle of the icon collection, for example, drag
the right scroll box to the middle of the scroll bar.

To move just a little at a time, click the scroll arrow that points in the
direction of what you want to see, or click in the gray areas of the
scroll bar.

Closing a window

To close a window, click the close box in the upper left corner of the
window. This has the same effect as choosing the Close
command from the File menu.

The keyboard and the DeskTop

If you prefer, you can control the DeskTop with keystrokes instead of
with the mouse. This section explains how to select icons, pull
down menus, choose from menus, and manipulate windows without
using the mouse. If you like using the mouse, skip this section

Selecting icons with keystrokes

Press G-H to highlight an icon. Press Right Arrow or Left Arrow to
highlight a different icon on the desktop or in the active window.
When the appropriate icon is highlighted, press Return to select it.

Press G-A to select all the icons on the desktop and in the active
window.

The keyboard and the DeskTop 9



You can also choose a command
by typing the key combination
shown to the right of some
commands on pull-down menus.
For example, you can press 3-O
to open a selected icon.

Choosing menu commands with keystrokes

Press Esc to indicate that you want to choose a command from a
menu. When you do, 2 menu is pulled down. Press Left Arrow or
Right Arrow to pull down a different menu. Press Up Arrow or Down
Arrow to highlight the command you want, then press Return to
choose the selected command.

Controlling windows with keystrokes

Press G-W to activate a window. Press Left Arrow or Right Arrow to
activate other windows on the desktop.

Press G-G to indicate that you want to change a window’s size, then
use the arrow keys to change the size. Press Return to select the new
size.

Press G-M to indicate that you want to move a window, then use the
arrow keys to move the window. Press Return to select the new
position.

Press G-X to indicate that you want to scroll through the contents of
a window, then use the arrow keys to scroll.

10 Chapter 2: Learning to Use the Mouse and the DeskTop



Chapter 3

Getting Started
With the DeskTop

This chapter explains the most basic way to use the DeskTop to
manage your files and start your applications.

But the DeskTop can do more than the basics. When you’re ready to
see what else the DeskTop can do, experiment with some of the
other menu items not discussed in this chapter. If you want to read
more, Chapter 4 reviews all the menus, command by command.

Working with files

The DeskTop lets you display the files on a disk and copy or delete
them by moving icons.

Viewing the contents of a disk

When you open a disk, the DeskTop displays its files as icons in a
window. By using the commands on the View menu, you can see
more information about these files and also change the order in
which they are displayed:
m Select and open a disk.

m Choose By name from the View menu. (The DeskTop lists the
files on the disk alphabetically by name and also provides other
information about the file.)

m Select another command to organize the files a different way.
Then, select By icon to return to the familiar view.

11
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Wwarning Do not insert two disks with the same name at the same time.

Copying files

The simplest way to copy a file is by moving its icon. When you drag
the icon of a file from one disk to another, the DeskTop copies the
file onto the new disk. When the process is complete, the original
file is still on the first disk and a copy of it is on the second disk.

To copy a file from one disk to another, follow these steps:
m Open the source disk and select the file to be copied.

m Drag the file icon to the destination disk icon. (You don’t have to
open that disk.)

® When the destination disk is highlighted, release the mouse
button.
The DeskTop displays an information screen as it copies the file.

You can copy a number of files at once by selecting multiple icons
and dragging the whole group to the destination disk. Make sure the
destination disk is highlighted before you release the mouse button.

Copying over existing files

The DeskTop warns you if the file you are copying already exists on
the destination disk and asks if you want to write over it. If you are
copying a newer version of a file, for example, click Yes. If you're
unsure, click Cancel and check to see what’s in the other file before
you copy over it.

& Note: If you are copying multiple files over existing files, you
can click All and the DeskTop will copy them all, without
interruption.

Chapter 3: Getting Started With the DeskTop



Warning

Organizing files into folders

If you're copying an application which is made up of several files,
it's a good idea to copy the application into a folder. A folder keeps
the files together in case you want to move them again, and your
desktop will be easier to scan.

m Open the destination disk.
m Choose New Folder from the File menu.

m You'll see a message that asks you to type the folder’s pathname.
The DeskTop has already provided the first part of the
pathname—the disk name—so all you need to do is type the
folder name and click OK. Make sure the folder name is no
longer than 15 characters.

m Drag the files you want to put in the folder onto the folder icon,
and release the mouse button when the folder icon is
highlighted.

% Note: When you copy files into a folder, the original files
remain where they were. Delete these originals if you want to by
dragging them to the Trash.

Deleting files

To delete a file, drag its icon to the Trash, releasing the mouse
button when the Trash icon is highlighted. A dialog box will appear
indicating that when you click OK, your files will be permanently
removed. If you're sure that's OK, click OK.

You can delete a number of files at once by selecting multiple icons
and dragging the whole group to the Trash.

Once files have been deleted, they cannot be recovered.

Working with files 13



Warning

Write-protecting disks is
explained in your disk drive
manual.

Working with disks

The DeskTop makes formatting and erasing disks easy. And it lets
you make backup disks just by moving icons.

Formatting a disk

Use Format a Disk when you want to prepare a blank disk for
new files.

Follow these steps, and the directions on the screen, to format a
disk :

m Insert the disk to be formatted into any drive.

Choose Format a Disk from the Special menu.

Select the location of the disk and click OK.

Type a name for the disk and click OK.

If asked, confirm that you want to erase the current contents of
the disk.

Formatting a disk erases everything stored on the disk so you
should only format blank disks or disks you want to erase and
recycle.

% Recycling tip: If a disk has already been formatted for the
Apple II and you just want to erase it, it's faster to use the
Erase a Disk command.

Copying a disk by dragging an icon

If you have two drives of the same size (for example, two 3.5-inch
drives), you can make a backup disk just by dragging an icon.

To copy a disk, follow these steps:
m Write-protect your source disk.
m Insert the source disk into any drive.

m Insert the destination disk, newly formatted or erased, in the
other drive.

14 Chapter 3: Getting Started With the DeskTop



m Drag the source disk icon to the destination disk, releasing the
mouse button when the destination disk icon is highlighted.

The DeskTop displays an information screen during the copying
process.

% Note: You can also make a backup by copying the disk contents
onto a larger capacity disk—for example, copying a 5.25-inch
disk onto a 3.5-inch disk. In this case, the destination disk does
not have to be newly formatted, but it must have enough space
for all the files you will be copying.

Pressing Esc in the middle of a disk copy stops the procedure as
soon as the current file has been copied.

Copying a disk using only one drive

If you have only one drive of a particular size, you have to use Disk
Copy from the Special menu to make a backup. (There are also
other uses for this command. For more information, see “Disk
Copy” in Chapter 4.)

Follow these steps, and the directions on the screen, to copy a disk:
m Write-protect your source disk.

Choose Disk Copy from the Special menu.

Choose Disk Copy from the Facilities menu.

When you see Select source disk, select the slot and drive
you want to use and click OK.

m When you see Select destination disk, select that slot
and drive again and click OK.

m Follow the screen directions to insert the source and destination
disks in turn.

m If asked, confirm that you want to destroy the contents of the
destination disk.

m Follow the screen directions to insert the source and destination
disks until the copy process is complete.

Working with disks 15



At this point, the DeskTop displays the Copy Disk screen again.
Select Quit from the File menu to return to the desktop.

% Note: You can stop this process at any time by pressing the Esc
key. Then, click OK to return to Copy Disk. After that, you
can start again, or choose Quit from the File menu to return
to the desktop.

Starting applications

With the DeskTop you can see all the files on a disk, so it’s easy to
select and start applications. Just follow these steps:

m Select the disk icon and choose Open from the File menu, or
double-click the appropriate disk to open it and see its files.

m Select the program icon and choose Open from the File menu,
or double-click the program you want to run. (If an application
comprises several files, open the icon whose filename includes
the word System, such as Aplworks.System.)

% BASIC programmers: To run a BASIC program from the
DeskTop, there must be a copy of the file called

You'll find a copy of BASIC.SYSTEM on the same disk as your program, and the
g')zsr'g’:vg}fk“' on the Apple lics BASIC.SYSTEM file must be in the same directory or in a

higher-level directory than the program. For example, you
could have BASIC.SYSTEM and your program files in the main
directory, or you could have BASIC.SYSTEM in the main
directory and your program files in a subdirectory.

Returning to the desktop

Many programs let you quit when you are finished. When you use
these programs with the DeskTop, they return you to the desktop. If
you end a program without returning to the desktop, simply restart
the DeskTop. Hold down the Apple and Control keys while you
press the Reset key; then release the keys, letting go of Reset first.

16 Chapter 3: Getting Started With the DeskTop



Chapter 4

Using the DeskTop’s
Advanced Features

This chapter is a quick reference for users who want to explore more
of the DeskTop’s capabilities.

The sections are arranged to correspond to the menus, reading
from left to right across the menu bar. Each menu item is
explained.

The desk accessories menu

The ® menu contains desk accessories—miniature applications like
a calculator and a puzzle. These mini-applications are available
only when you’re using the computer desktop.

When you're finished using a desk accessory, click the close box in
the upper-left corner of the window.

Calculator

The Calculator accessory works like a four-function calculator. Click
the number buttons and function buttons to perform quick
calculations.

% Note: The key marked e stands for exponent.

17



Puzzle

The puzzle gives you something to work on when you need a break.
Click on any tile to begin, then click a tile to slide it into the empty
space. The object is to arrange the tiles into the original design.

Date

The Date accessory displays a date which the DeskTop uses to mark
a file’s creation or modification date.

To adjust the display, click one of the boxes (day, month, or year)
and then use the arrows to change the settings.

Show Text File

This accessory lets you view the contents of an ASCII text file, so
there’s no need to start an application in order to see what’s in a
particular file.

Sort Directory

This accessory lets you designate how file icons will be arranged
when you first open a disk or folder, so you can store the icons you
use most frequently at the top of the window. To sort a directory,
hold down the Apple key and click the icons in the order you want
them to appear in the window. After you've clicked all the icons you
want to arrange, choose Sort Directory, and the first icon you
clicked will appear in the upper-left corner, the second icon you
clicked will be just to the right of that, and so on.

< Note: You can rearrange icons by dragging them, but they will
revert to their original positions the next time you open that
window unless you use Sort Directory to reposition them.

18 Chapter 4: Using the DeskTop's Advanced Features



The key combinations shown to
the right of command names in
this section indicate that you
can choose the command by
pressing these keys instead of
by choosing the command from
the menu.

See the appendix for more on
pathnames.

The File menu

These commands are used for most of your work with disks and files.

New Folder (Apple-F)

This command creates a folder when a disk or folder is open. The
DeskTop asks for the new folder’s pathname and provides the name
of the disk. Simply type a name for the folder and click the OK
button.

Use folders to organize your files into a few general categories or to
hold the files of an application program.

When you drag an icon into a folder, the original remains where it
was. So if you use folders to organize your desktop, make sure to
delete duplicate files.

% Note: When a file is in a folder, the folder's name becomes
part of the file’s pathname.

Open (Apple-0)

Selecting an icon and choosing Open is an alternative to double-
clicking an icon. Use it to display the contents of a disk, file, or
folder or to run a program.

Close (Apple-C)

An alternative to using the close box, this command closes the
active window.

Close All (Apple-B)

This command closes all the windows on the desktop.

Select All (Apple-A)

Select All highlights all the icons in the active window. If no
windows are open, the command highlights all the icons on the
desktop.

The File menu 19
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Copy a File (Apple-Y)

Copy a File is an alternative to copying a file by dragging an
icon. When a file is deep within directories, using this command
may be faster.

To enter the source name, change the drive, if necessary, open the
appropriate folders, and select the filename. When you click OK,
the DeskTop enters a default destination pathname. Accept this
pathname, or edit it, using the mouse or the keyboard.

When the pathnames are correct, click the OK button.

% Note: To copy a whole disk, use the Disk Copy command in
the Special menu.

Delete a File (Apple-D)

Use Delete a File as an alternative to deleting a file by
dragging an icon to the Trash. This command may be quicker when
the file is deep within a directory.

Eject (Apple-E)

This command ejects the selected 3.5-inch disk from its drive.

Quit (Apple-Q)

This command displays the Selector if there are entries in the Run
list. Otherwise, it returns to the desktop.

% Note: The Selector is a menu that works in conjunction with the
Run list. If there are any entries in the Run list, the Selector
displays them when the DeskTop is first started up. Users can
choose to run a program from the list or proceed to the
desktop.
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The View menu

The DeskTop displays files as icons. These commands let you
display the directories in other ways.

By Icon (Apple-J)

The By Icon view is the default view. It shows the contents of the
active window as icons.

By Name (Apple-N)

This command shows the contents of the active window
alphabetically, by name.

By Date (Apple-T)

This command shows the contents of the active window
chronologically, by last modification date.

By Size (Apple-K)

By Size shows the contents of the active window in descending
order, by size.

By Type (Apple-L)

The By Type command shows the contents of the active window,
alphabetically, by file type.

The View menu 21



The Special menu

These commands are used for working with disks and files, but less
frequently than those in the File menu.

Check Drives

This command lets you update the desktop after you change the
disks in the drives.

< Note: You need to use this only for 5.25-inch disk drives; the
DeskTop checks the 3.5-inch disk drives automatically.

Format a Disk (Apple-S)

Format a Disk prepares a disk for ProDOS files. If a disk has
already been formatted, use Erase a Disk to remove the old
data.

Erase a Disk (Apple-2)

This command removes all old data from a disk. Erasing is much
faster than formatting.

Disk Copy

Use this command to make a backup copy of a disk. It’s faster than
copying a disk by moving its icon. And, it's the only way to copy a
disk when the disk format is DOS 3.3 or Pascal or when you want a

same-size copy (for example, 3.5-inch to 3.5-inch) and you have
only one drive of that size.
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This command provides two copy programs. Quick copy is the
default, but you can use it only with ProDOS disks and when the
destination disk is already formatted.

To copy a disk using Quick copy:

m Follow the instructions on the screen to select the source and
destination drives. The DeskTop prompts you to insert the
source and destination disks as required.

m Select Quit from the File menu to return to the DeskTop.

To use the other copy program, select Disk copy from the
Facilities menu. The instructions are the same as for Quick copy.

% Note: If a disk has a non-standard operating system
(something other than ProDOS, DOS 3.3, or Pascal), you may
not be able to copy it. Consult that program’s manual for
instructions about making backup copies.

Lock

Lock prevents the contents of a file or disk from being
inadvertently changed, discarded, or renamed.

Unlock

This command reverses Lock.

Get Info (Apple-l)

Get Info displays information, such as size and creation date,
about a selected file or disk. If you select multiple files before
choosing Get Info, click the OK button to display successive
information screens.
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Warning

Get Size

Use this command to check the total size of a group of files you have
selected. Press OK to return to the desktop.

Rename an Icon

Use this command to change the name of a file, folder, or disk.
Rename an Icon is available when any icon but the Trash is
selected.

The Startup menu

The DeskTop only displays icons for ProDOS disks. The Startup
commands let you start up a non-ProDOS disk.

Be sure that the disk you want to start contains an application.
If you use a data disk, for example, it won’t hurt the disk, but
the DeskTop will stop and you’ll have to restart it.

Insert the disk in a drive, and choose the appropriate slot from the
menu; the DeskTop will start it.

% Note: In most cases, your drives will be attached in such a way
that selecting Slot 5 will start up 3.5-inch disks and selecting
Slot 6 will start up 5.25-inch disks.
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Warning

The Selector menu

These commands let you create a Run list for quick program
selection. Items in the Run list also appear on the Selector, so you
can run them at startup without going to the desktop.

Add an entry
This command adds items to the Run list.

The DeskTop allows up to eight items to be added to the Run menu.
An additional 16 may be stored in the Other Run list, and both lists
are displayed in the Selector. Click the appropriate box on the far
right side of the command screen to put an entry in the Other Run
list.

m Enter the program name by selecting its drive, opening a folder,
if necessary, and selecting its filename. Click OK and then type
the name as you want it to appear in the Run list or accept the
name suggested by the DeskTop.

m If you have a RAM card and want the DeskTop to download a Run
list program, click the appropriate box on the right side of the
screen.

m Click OK when all the screen entries are correct.

Be sure that the entries in the Run list are applications. If they
are not, the DeskTop may stop and you will have to restart it.

Edit an entry

Use this command to change an existing entry. Follow the
instructions to select the entry, correct the information displayed,
and then click OK.
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Delete an entry

This command removes an entry from the Run list. Follow the
instructions to select the entry and then click OK. Click Cancel to
return to the desktop.

Run an entry (Apple-0)

This command displays the contents of both the Run list and the
Other Run list.
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Appendix

About Pathnames

A pathname is the full name of a file. Using a pathname tells the
Apple II how to find a particular file. The pathname begins with the
name of the disk (volume), then names any folders (subdirectories),
and ends with the actual filename.

Each name in the pathname is separated by a slash. For example,
the pathname for a letter named PROPOSAL you’re saving on a disk
called DATA might be /DATA/PROPOSAL. If the file is in a folder,
the pathname will be something like /DATA/JULY/PROPOSAL.

Whenever you refer to files within folders, be sure to include the
name of the folder when you write the pathname.

Writing pathnames

There are certain rules to follow for naming files and writing
pathnames.

m Use a slash at the beginning of the pathname and to separate the
individual names.

m Start each name with a letter.
m Don’t make any individual name longer than 15 characters.

® You can use letters, numbers, and periods, but no other
punctuation marks.
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Using a prefix

When the DeskTop needs a pathname, it often displays a prefix—
the first part of a pathname. You can accept the prefix and just type
the remainder of the pathname, or you can edit it, or erase it
entirely and type the name you want.
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